Net Tool Box - The Ultimate Mac Networking Utility


| About | Features | Order | Support

Net Tool Box Documentation

What's So Special About Net Tool Box?
The reason Net Tool Box is the best Networking Utility around, is not because of various tasks it can perform as a unit, but because of its format.
Net Tool Box is like a big grab bag of networking tools. Importantly, the tools talk to each other; which makes it much easier and quicker to get the job done. Because they all share resources, they converge to make the user experience more productive.

Using Tools
When you first open Net Tool Box, you are presented with a message asking you to buy the software. Click "OK" to dismiss it. You will then see a "Mail List" registration window. This allows sign up to the Nettlesting updates list. If you decide not to sighn up, you can go back to register at a later stage to register by choosing "Help" > "Join Nettlesting Mail List".

A toolbar appears at the top of the screen. It will display your current IP address under the "Net Tool Box" text on the right. You can click on the IP menu to show a list of quick functions available to use with your IP.
If you prefer not to use the toolbar, you can close it or toggle the "Edit" > "Show Toolbar" menu item.
You can also easily select a tool from the Dock Menu. This is accessed by control-clicking on the Net Tool Box Icon from within the dock. This only works when Net Tool Box is running.

Authorization
A known-issue in previous versions of Net Tool Box was that many low-level operations (mainly ping, listener terminals and UDP terminals) were prohibited to the user unless they log on to OS X as the "root" user. For many people this was an inconvenience, so now there is a built in an "Authorize" feature. This lets you type your admin password straight into Net Tool Box, to activate these 'root-only' tools.
If you are using a tool that needs to be authenticated to use, just choose "Edit" > "Authorize". This will display the well-known OS X "Authenticate" window asking for your Administrator password. Once you successfully authorize, Net Tool Box will quit and re-open itself as a "root" process, giving it access to the low-level socket functions used in the required tool.
If you often use Net Tool Box in the authorized state, you can automatically authenticate at application launch. This option is accessible via the "General" pane of the Preferences window.

Favorites
In each tool, where appropriate, there is a "favorites" menu, usually next to each "host" field. Here you can select a host you regularly use. These hosts are also accessible using the "AutoComplete" feature. You will notice AutoComplete working when you start typing into a host field. If it recognizes anything you have started to type, it predicts the text in a greyed state. If you hit the tab key, it will AutoComplete the text suggestion. AutoComplete is active by default, but you can disable it from the preferences window.
Your favorites can be changed by selecting "Edit favorites" from any of the Favorites Drop-Down Menus, or by selecting Window > Favorites (Command - F). This will display the Favorites window. You can then add, delete and edit your favorites using the toolbar.

Interfaces
Net Tool Box has a useful utility that lets you see all your Network Interface information. You can access it via the "Edit" menu (or by typing command-i). A palate appears on the right hand side of your screen, displaying a list of all the attached (enabled) Network Interfaces and their properties.

Window Manipulation
You can easily show and hide any current tools you are working with by using the "Window" menu. To minimize the current item you are working on the dock, select Window > Minimize (Command - M). You can retrieve them by clicking on the dock icon, or by selecting the tool from the Window Menu. You can minimize all the open tools by choosing Window > Minimize All (Command - Option - M).

Preferences
The preferences are accessible via the Application Menu (or with the command-comma shortcut). In the preferences window, you have the ability to control how Net Tool Box will behave. The "General" pane, has general purpose settings such as "Use AutoComplete" and "Check for new versions".
In the "Appearance" pane there is a "Fixed-Width Font" menu, Which determines which font the reporting-tools use (eg Whois, and Terminals). Bear in mind that for this to work correctly, the chosen font MUST be a fixed-width typeface, such as Courier or Monaco (default). There is also an option to make inactive windows transparent, useful when using many windows.

Port Database
Net Tool Box is equipped with a fully functional port database. It holds over 2500 officially reserved port numbers along with their official names and descriptions. The list is available under Help > Port Numbers. Once open, the list will show a list of ALL ports in the database in numerical order. You can add delete and edit port numbers for your own reference, however you should remember that if you edit or delete a port by mistake, the only way to revert the database is to reinstall Net Tool Box.
To edit a port, either double click on it in the list or highlight it and click the "Edit" item in the window's toolbar. This will display a sheet allowing you to edit the port number, name and description. If you choose a port number that is already used you will be asked to choose a different one.
Adding a port is done in the same way. Click the "New" button on the window 's toolbar to display a blank edit dialog. Type a port number, name and description and click "Add". Again, if the port number is in use you will be asked to choose a different one
To remove a port from the database, highlight the port you wish to delete and click the "Delete" button. A dialog will appear asking if you to confirm. By pressing "OK" at this stage, the port, it's name and description will be permanently removed from the database.

You can search the database for specific ports by clicking the "Search" item on the window's toolbar. This will display the search dialog. Here you can specify the criteria for your search. If you want to search for a specific number, you can type it directly into the "Port No" field. If you want to find a partial text match from either the name or description fields, you can type the text to match and choose between one of the logical operators (contains, begins with, ends with or equals for an exact match).
The "Operator" option will determine whether all of your criteria are matched (if in the "AND" state) or if any of the criteria are met (if in the "OR" state.
By clicking "Find", Net Tool Box will search the database with your criteria. If at this point no records are found, a message will appear saying "No records found". If there were results yielded from your search the search dialog will be dismissed and your results shown in the list.
To show all the ports again, click the "Show All" item on the right hand side of the window's toolbar.

Documentation Index


© Charlie Boisseau 2005
54.236.180.104

Valid HTML 4.01! Valid CSS!